Compatibility matrix

Wazuh software can be installed on many operating systems. In addition, there are also specific compatibility requirements between the different components of Wazuh. For more information, check the compatibility matrix below.

Operating system compatibility

Wazuh manager

Below you may find the compatibility table for the Wazuh manager.

Operating System

Wazuh version

From 3.13.x to current

From 3.0.x to current

2.1.1

2.1.0

Amazon Linux 1 or newer

CentOS 6 or newer

Debian Wheezy/7 or newer

Fedora (>= 31)

OpenSUSE 42 or newer

Oracle Linux 6 or newer

Raspbian Pi OS Stretch/9 or newer

RHEL 6 or newer

SUSE 12* or newer

Ubuntu Precise/12.04 - 16.10

Ubuntu Zesty/17.04 or newer

(*) SUSE based host are available as Wazuh manager since Wazuh v3.2.1 version.

Wazuh agent

In this table, you can check our supported OS list where the Wazuh agent can be installed.

Operating System

Wazuh version

From 3.13.x to current

From 3.3.1 to current

AIX 5, 6 and 7

Amazon Linux, Amazon Linux 2

CentOS 5 or newer

Debian Wheezy/7 or newer

Fedora 31 or newer

HP-UX 11.31

macOS Sierra or newer *

OpenSUSE 42 or newer

Oracle Linux 5 or newer

Raspbian Pi OS Stretch/9 or newer

RHEL 5 or newer

Solaris 10 and 11 - i386 / sparc

Suse 11 or newer

Ubuntu Precise/12.04 or newer

Windows XP or newer

Windows Server 2003 or newer

* With the release of macOS Catalina the packages are required to go through notarization. Version 3.10.2 was the first version to be notarized, this means that packages for versions older than 3.10.2 are not compatible with macOs Catalina.

Components compatibility

When using the full stack of Wazuh software (that means, wazuh-manager, wazuh-agent and wazuh-wui), there are different compatibility requirements in order to make everything work properly.

Manager and agents

The compatibility between the Wazuh agent and the Wazuh manager is guaranteed when the Wazuh manager has a newer or equal version than the Wazuh agent.

Note

The Wazuh manager is also compatible with OSSEC agents, however, not all capabilities will be available for them.

Wazuh and Wazuh Kibana plugin

The Wazuh app for Kibana requires compatibility between two different components:

  • With the Wazuh manager, it requires the same major.minor version.

  • With the Elastic Stack, it is only compatible with the exact same version.

Wazuh version

Elastic Stack version

Open Distro version

4.2.4

7.10.2

1.13.2

4.2.4

7.11.2

4.2.4

7.12.1

You can find more information on the Wazuh app for Kibana repository, where you can check a more detailed compatibility matrix between the Wazuh app and Elastic Stack versions.

Wazuh and Splunk app

The Splunk app for Wazuh requires compatibility between two different components:

  • With the Wazuh manager, it requires the same major.minor version.

  • With Splunk, it is only compatible with the exact same version.

Splunk App version

Splunk version

4.2.4

8.1.4, 8.2.2

You can find more information on the Wazuh app repository, where you can check a more detailed compatibility matrix between the Wazuh app for Splunk and Splunk versions.