Compatibility matrix

Wazuh software can be installed in many operating systems, but depending on your needs, some systems may not be compatible. In order to assist you, check the following compatibility matrix.

Manager

Below it shown the compatibility table for the Wazuh manager. It is recommended using CentOS / RHEL 7 as the operating system for Wazuh managers, due to their stability and full compatibility with the Wazuh modules.

Operating System

Wazuh version

2.1.0

2.1.1

3.0.0

3.1.0

3.2.0

3.2.1

3.2.2

3.2.3

3.2.4

Debian Wheezy/7

Debian Jessie/8

Debian Stretch/9

Ubuntu Precise/12.04

Ubuntu Trusty/14.04

Ubuntu Vivid/15.04

Ubuntu Wily/15.10 *

Ubuntu Xenial/16.04

Ubuntu Yakkety/16.10

Ubuntu Zesty/17.04

Ubuntu Artful/17.10

Ubuntu Bionic/18.04

CentOS 5 / RHEL 5 *

CentOS 6 / RHEL 6 **

CentOS 7 / RHEL 7

Fedora (>= 22)

(*) In these systems, the Wazuh API is not available.

(**) To run the cluster in CentOS 6, check section Running the cluster in CentOS 6

Note

The cluster is available since Wazuh v3.0 and it doesn’t work on CentOS 5 / RHEL 5.

Agent

In this table, you can check our supported OS list where the Wazuh agent can be installed.

Operating System

Wazuh version

2.1.0

2.1.1

3.0.0

3.1.0

3.2.0

3.2.1

3.2.2

3.2.3

3.2.4

Debian Wheezy/7 or newer

Ubuntu Precise/12.04 or newer

CentOS 5 / RHEL 5

CentOS / RHEL 6 or newer

Fedora 22 or newer

Windows XP 2003 or newer

Windows Server 2008 or newer

Mac OS X

HP-UX 11.31 *

Solaris 10 - i386

Solaris 11 - i386

Solaris 10 - Sparc *

Solaris 11 - Sparc *

AIX 5 *

AIX 6

AIX 7

Suse 11

Suse 12

Amazon Linux

(*) In these systems, Wazuh agent v3.2.4 will be available soon.